Downloads

Important Notice from FlightGear developers

This is a download page for FlightGear Mac OS X, a free / open-source flight simulator.

We have heard that there are some paid products that use FlightGear, and their web site or a starting box seems leading you to this site for either downloading the binary or support. It's totally up to you for paying some amount of money for software and scenery that you can get for free. However, we have never received any donation or single penny on your payment for such paid product. Therefore we have no responsibility for providing any support for such products.

Generally speaking, it is better to get FlightGear for free and buy a good flight stick and/or a pedal. Needless to say, donation to FlightGear is very welcome :-) If you already paid for such product and feel very disappointed by knowing FlightGear is available for free, we recommend you ask the seller (not us) for refund. See the official statement for more detail on this issue.

Latest-release (2.6.0 - Feb-18-2012)

Note:

If you have any problem in downloading FlightGear, try downloading it from the following site:

Clicking FlightGear-2.6.0-r319.dmg will start downloading it.


Development snapshot (Latest snapshot pulled from git) - - Jun-02-2011

IMPORTANT NOTICE IN USE OF DEVELOPMENT SNAPSHOT

This release is a snapshot of the latest FlightGear source (git version), and it might have some major bugs. Thus, this release is NOT totally recommended for novice users. NEVER send me complaints on this release. However, constructive feedbacks and bug reports from developers and advanced users are very welcome. Consult ReadMe file included in the dmg package for known issues.



Source Package



Keyboard configuration file (for v1.0)

I've heard that some Macs cannot handle throttle keys or some others properly. Thanks to Aj MacLeod, we can use the fixed keyboard.xml, which might enable some Mac to properly handle throttles, etc. See the link below to download the revised keyboard.xml file at the "Attached files" section. Read the explanation at the tracker info for installation instruction.

Older versions

2.4.0 - Aug-17-2011

fgcom fix for Mac OS X 10.5 users

fgcom in 2.4.0 release package does not work on OS X 10.5 since a part of it is built for OS X 10.6 or later. This causes the simulator running on OS X 1.5 unexpected exit when fgcom is enabled. To fix this, you can download and install this fgcom. Installation procedure is 1) Select advanced features >> Others >> Install Add Ons, 2) Select the downloaded fgcom.

2.0.0 - Mar-18-2010

1.9.1-r232 - Sep-06-2009

1.9.0 - Dec-22-2008

1.0.0 - Jan-16-2008

0.9.10 - Dec-15-2006

Older updaters

1.0.0-r154

0.9.10

You can also download Older versions from sourceforge download page. FYI, 0.9.8 runs on Mac OS 10.3.9.